[Résolu] Reprise d'un projet GDevelop 4 avec GDevelop 5


#1

Bonjour à tous,
j’ai commencé un RPG en 2017 avec Gdevelop 4. Je précise la date car j’aimerais le reprendre mais ne sais même plus comment ouvrir ma sauvegarde avec Gdevelop 5.

Pouvez-vous m’aider pour importer un projet GD4 vers GD5.

Voici le répertoire dans lequel j’a tout sauvegarder…

Merci de votre aide !

A202


#2

Bonjour. Il vous suffit d’ouvrir le fichier dont vous avez besoin avec l’extension .gdg - les fichiers portant l’extension .gbg.autosave s’ouvriront automatiquement à l’ouverture du fichier.

P. S: Au fait, quand j’ai regardé le mot “DETECTIVE”, je me demandais à quoi ressemblait votre jeu?


#3

Merci ! Voici donc maintenant les messages que j’ai :
image


image

Comment puis-je résoudre ça ?
merci :slight_smile:


#4

Essayez de lire à ce sujet: Unable to open project (even old versions)


#5

merci.

J’arrive donc à l’ouvrir avec GD4 mais pas avec GD5. J’ai donc tout sauvegarder dans un nouveau répertoire, pour que cela soit plus propre. Mais rien n’y fait…

Si vous avez des idées…


#6

J’ai une question: quel âge a votre fichier?


#7

Il date de 2017… ça fait loin informatiquement parlant. J’ai l’impression que ce n’est plus compatible…

voici une vue du jeu (une seul scène pour l’instant, il faut que je travaille le scenario). J’avais commencé sur scratch avec des génération de tableau automatique et aléatoire et un système de labyrinthe… Bref.

Merci une … quatrième fois :blush:


#8

Je ne peux pas dire avec certitude, mais le fichier, qui… 2 ans, ne sera probablement pas pris en charge dans GDevelop 5…


#9

Ne mélangeons pas tout.
Les fichiers GD4 sont en .gdg, ils sont uniquement ouvrable avec GD4.
Les fichiers GD5 sont en .json, ils sont ouvrable avec GD5.

Pour ouvrir un fichier GD4 dans GD5 il faut au préalable l’ouvrir dans GD4 et faire “Enregistrer sous” le projet et choisir l’extension de fichier .json
La doc est ici pour la procédure :
http://wiki.compilgames.net/doku.php/gdevelop5/getting_started/open-gdevelop-4-project#open_a_game_made_with_gdevelop_4

Ensuite il sera ouvrable avec GD5.
Il se peut que certaines partie qui était sous GD4 ne sont pas encore sur le 5, notamment des extensions. Donc si c’est le cas, le jeu devra être retravaillé pour supprimer les extensions non compatibles. Ce que vous devez faire manuellement.

Un exemple simple: si un jeu GD4 utilise l’extension lumière, même si il est porté dans GD5, ça ne fonctionnera pas car l’extension n’est pas disponible dans le 5.

Concernant la compatibilité un maximum est fait pour que ce qui est fait sur une version soit compatible avec la suivante.
Par-contre si vous allez d’une version récente à une version un peu plus ancienne là c’est pas compatible.


How to open .gdg in gdevelop
#10

@Bouh, thank you for reminding me of the difference. I’ve been in GDevelop for a long time and I forgot the differences between .gdg and .json extensions :sweat:


#11

Un grand merci pour une réponse si détaillée et précise. Effectivement, j’ai réussi à ouvrir le projet dans GD5 avec juste un soucis de sprite manquant. Mais tout le reste fonctionne parfaitement.

Merci du temps passé à résoudre mon problème et pour les explications claires.

Merci aussi Diana. J’ai lu ton profile, tu devrais te remettre à gdevelop, c’est vraiment bon de voir son petit jeu tourner ! (mais chronophage :wink:)

Bonne journée à vous deux