Please use a standard installer


#1

I double-clicked the setup icon, the mouse icon just showed that it’s loading but nothing happened for minutes. I even checked the task manager but couldn’t find the exe in there. Eventually the main window of GDevelop popped up. I was never asked where I want to install it, I surely didn’t want it to be installed in my user account in a cryptic subfolder of a cryptic subfolder! Please install it correctly in the programs folder and ask us for the admin password if our Windows system has multiple accounts.


#2

Try it:


#3

hi it would be nice to include some option to select the folder to install. Anyway you can then move the folder whereever you want and gdevelop continue working, is kind of portable app, the problem is updating, it will go to the initial path.
Before I opened the setup exe with 7zip and extracted but in beta 75 something changed and couldn’t see the files inside :frowning:


#4

I do have admin rights. I have an admin and a user account on my Windows system, and generally log in as user for everyday use. If I install other software with that account, the setup usually asks for the admin password (which I clearly know, because it’s my computer) and later on the software lets me choose the installation folder.

I want GDevelop to do the same. I don’t want any software to be installed automatically in my user folder, software belongs into the programs folder.


#5

i agree with you but you can easyly move it to any folder you like