I can't uncheck "share same collision masks for all animations"


#1

I try to uncheck them for every animation but they are all checked again the second time I try to view it. The same is true for points. If I try to edit one I change all.
I guess this is a bug in the editor? If anyone knows a workaround I’d apreciate it.


#2

My understanding is that changes to points/hitboxes aren’t applied until you actually hit the “Apply” on the main object.

So if you’re choosing “edit hitbox”, changing the setting, closing that window, but still keeping the object window open and going back in, it will not reflect your changes.

If you’re not doing that, I’m not sure as I can’t reproduce what you’re experiencing.


#3

I had this same problem. Are you unchecking it, then creating a custom mask for that animation? What finally worked for me was unchecking “share same mask for all animations”, creating a custom mask for that animation, THEN moving on to another animation from the dropdown menu. That was the only way I could get it to work.