Unable to install GDevelop


#1

Hey there,
I’ve been trying to install GDevelop using the GitHub source code. Node.js and npm are already installed. But when I run “npm install” in GDevelop/newIDE/app, it gives me the following output:

npm WARN addRemoteGit Error: Command failed: git config --get remote.origin.url
npm WARN addRemoteGit 
npm WARN addRemoteGit     at ChildProcess.exithandler (child_process.js:275:12)
npm WARN addRemoteGit     at emitTwo (events.js:126:13)
npm WARN addRemoteGit     at ChildProcess.emit (events.js:214:7)
npm WARN addRemoteGit     at maybeClose (internal/child_process.js:925:16)
npm WARN addRemoteGit     at Socket.stream.socket.on (internal/child_process.js:346:11)
npm WARN addRemoteGit     at emitOne (events.js:116:13)
npm WARN addRemoteGit     at Socket.emit (events.js:211:7)
npm WARN addRemoteGit     at Pipe._handle.close [as _onclose] (net.js:567:12)
npm WARN addRemoteGit  git://github.com/4ian/lingui-react.git#master resetting remote /home/piyush/.npm/_git-remotes/git-github-com-4ian-lingui-react-git-master-b5d9f0dc because of error: { Error: Command failed: git config --get remote.origin.url
npm WARN addRemoteGit 
npm WARN addRemoteGit     at ChildProcess.exithandler (child_process.js:275:12)
npm WARN addRemoteGit     at emitTwo (events.js:126:13)
npm WARN addRemoteGit     at ChildProcess.emit (events.js:214:7)
npm WARN addRemoteGit     at maybeClose (internal/child_process.js:925:16)
npm WARN addRemoteGit     at Socket.stream.socket.on (internal/child_process.js:346:11)
npm WARN addRemoteGit     at emitOne (events.js:116:13)
npm WARN addRemoteGit     at Socket.emit (events.js:211:7)
npm WARN addRemoteGit     at Pipe._handle.close [as _onclose] (net.js:567:12)
npm WARN addRemoteGit   killed: false,
npm WARN addRemoteGit   code: 1,
npm WARN addRemoteGit   signal: null,
npm WARN addRemoteGit   cmd: 'git config --get remote.origin.url' }
npm WARN addRemoteGit Error: Command failed: git config --get remote.origin.url
npm WARN addRemoteGit 
npm WARN addRemoteGit     at ChildProcess.exithandler (child_process.js:275:12)
npm WARN addRemoteGit     at emitTwo (events.js:126:13)
npm WARN addRemoteGit     at ChildProcess.emit (events.js:214:7)
npm WARN addRemoteGit     at maybeClose (internal/child_process.js:925:16)
npm WARN addRemoteGit     at Socket.stream.socket.on (internal/child_process.js:346:11)
npm WARN addRemoteGit     at emitOne (events.js:116:13)
npm WARN addRemoteGit     at Socket.emit (events.js:211:7)
npm WARN addRemoteGit     at Pipe._handle.close [as _onclose] (net.js:567:12)
npm WARN addRemoteGit  git://github.com/4ian/pixi-simple-gesture.git#v3.0.0 resetting remote /home/piyush/.npm/_git-remotes/git-github-com-4ian-pixi-simple-gesture-git-v3-0-0-5d039d09 because of error: { Error: Command failed: git config --get remote.origin.url
npm WARN addRemoteGit 
npm WARN addRemoteGit     at ChildProcess.exithandler (child_process.js:275:12)
npm WARN addRemoteGit     at emitTwo (events.js:126:13)
npm WARN addRemoteGit     at ChildProcess.emit (events.js:214:7)
npm WARN addRemoteGit     at maybeClose (internal/child_process.js:925:16)
npm WARN addRemoteGit     at Socket.stream.socket.on (internal/child_process.js:346:11)
npm WARN addRemoteGit     at emitOne (events.js:116:13)
npm WARN addRemoteGit     at Socket.emit (events.js:211:7)
npm WARN addRemoteGit     at Pipe._handle.close [as _onclose] (net.js:567:12)
npm WARN addRemoteGit   killed: false,
npm WARN addRemoteGit   code: 1,
npm WARN addRemoteGit   signal: null,
npm WARN addRemoteGit   cmd: 'git config --get remote.origin.url' }
npm WARN deprecated material-ui@0.20.2: You can now upgrade to @material-ui/core
npm WARN deprecated keen-tracking@1.1.3: deprecated
npm WARN deprecated url-search-params@1.1.0: now available as @ungap/url-search-params
npm ERR! git clone --template=/home/piyush/.npm/_git-remotes/_templates --mirror git://github.com/4ian/pixi-simple-gesture.git /home/piyush/.npm/_git-remotes/git-github-com-4ian-pixi-simple-gesture-git-v3-0-0-5d039d09: Cloning into bare repository '/home/piyush/.npm/_git-remotes/git-github-com-4ian-pixi-simple-gesture-git-v3-0-0-5d039d09'...
npm ERR! git clone --template=/home/piyush/.npm/_git-remotes/_templates --mirror git://github.com/4ian/pixi-simple-gesture.git /home/piyush/.npm/_git-remotes/git-github-com-4ian-pixi-simple-gesture-git-v3-0-0-5d039d09: fatal: unable to connect to github.com:
npm ERR! git clone --template=/home/piyush/.npm/_git-remotes/_templates --mirror git://github.com/4ian/pixi-simple-gesture.git /home/piyush/.npm/_git-remotes/git-github-com-4ian-pixi-simple-gesture-git-v3-0-0-5d039d09: github.com[0: 140.82.118.3]: errno=Connection timed out
npm ERR! git clone --template=/home/piyush/.npm/_git-remotes/_templates --mirror git://github.com/4ian/lingui-react.git /home/piyush/.npm/_git-remotes/git-github-com-4ian-lingui-react-git-master-b5d9f0dc: Cloning into bare repository '/home/piyush/.npm/_git-remotes/git-github-com-4ian-lingui-react-git-master-b5d9f0dc'...
npm ERR! git clone --template=/home/piyush/.npm/_git-remotes/_templates --mirror git://github.com/4ian/lingui-react.git /home/piyush/.npm/_git-remotes/git-github-com-4ian-lingui-react-git-master-b5d9f0dc: fatal: unable to connect to github.com:
npm ERR! git clone --template=/home/piyush/.npm/_git-remotes/_templates --mirror git://github.com/4ian/lingui-react.git /home/piyush/.npm/_git-remotes/git-github-com-4ian-lingui-react-git-master-b5d9f0dc: github.com[0: 140.82.118.3]: errno=Connection timed out
npm ERR! Linux 4.15.0-48-generic
npm ERR! argv "/usr/bin/node" "/usr/bin/npm" "install"
npm ERR! node v8.10.0
npm ERR! npm  v3.5.2
npm ERR! code 128

npm ERR! Command failed: git clone --template=/home/piyush/.npm/_git-remotes/_templates --mirror git://github.com/4ian/pixi-simple-gesture.git /home/piyush/.npm/_git-remotes/git-github-com-4ian-pixi-simple-gesture-git-v3-0-0-5d039d09
npm ERR! Cloning into bare repository '/home/piyush/.npm/_git-remotes/git-github-com-4ian-pixi-simple-gesture-git-v3-0-0-5d039d09'...
npm ERR! fatal: unable to connect to github.com:
npm ERR! github.com[0: 140.82.118.3]: errno=Connection timed out
npm ERR! 
npm ERR! 
npm ERR! 
npm ERR! If you need help, you may report this error at:
npm ERR!     <https://github.com/npm/npm/issues>

npm ERR! Please include the following file with any support request:
npm ERR!     /home/piyush/GDevelop/newIDE/app/npm-debug.log

Any help would be helpful