Tiled Sprite Offset

How come my Offset sprite keeps distorting(Gets Blurry) as time goes on?, please help me.

i believe its cuz the image has smoothing on, turn it off via resource tab

Along with the suggestion of @darkshadow, that might also have to do with sub-pixel rendering (if its 9 Patch [I don’t know how it happens but I do know that you might face this issue]) so also try doing:
Change the X position of Camera set to round(CameraX())
Change the Y position of Camera set to round(CameraY())

Or check this in the Project’s Resources:
image


And also do this:
image

Note: These are all suggested only for Pixel Perfect games.

Thank you so much Mixen and @darkshadow, I have tried all your suggestions and still no good results. I think it’s a bug in the updated Gdevelop 5.

Can Kindly instruct me on how to turn off the Smoothing Effect Via resource tab?, Thank you.

Can you give a couple of screen shots of what you mean? Good quality snips of what it’s like before the offsets are changed, and then a snip of it blurry?

And while you do that, are your offsets whole numbers (i.e. 1,2,3,4,5 etc), so you’re moving whole pixels, and not part of a pixel? Depending on what you mean by blurry, offsets with decimal values could be causing it.

theres a button for it, click it and it should turn off

Here’s everything about Resources and how to turn the Smoothing off.
http://wiki.compilgames.net/doku.php/gdevelop5/interface/project-manager/resources#smoothing

Hey there Mrmen,Darkshadow and Mixen, here are short videos,wereI you can visibly see the changes. ThanksProcessing: SVID_20211121_105749.mp4…
Processing: SVID_20211121_105911.mp4…

Those links haven’t worked. You may need to put the videos elsewhere online and link to them.

Okay thanks, here are the links to the videos - YouTube and - YouTube.

Can you please watch the videos from the links.

Those videos are set to private. I can’t see them.

I fixed the problem you can now watch them, wow Really not in my game today :grinning:.
- YouTube And 369 PURE LYRICS - YouTube

Wow, in that second clip the image turns nasty. I wouldn’t call that blurry - it becomes pixelated. How are you offsetting?


As MrMen said, it becomes nasty, not blurry. Its Pixelated (Pixel Perfect) and when we change the position of object, there aren’t many pixels to work with so it theior are movement is blocky and not smooth. There are two workarounds here AFAIK:

  1. You can turn this off in the Project Properties to get some sub-pixel rendering but I don’t think that would help much.
    image

  2. Increase the resolution of both your project and assets 2x or 3x. But before doing this, backup your project so that if anything got messed up, you have backup to feel safe.

Thanks Mixen, I think it’s a bug in gevelop 5

Thank you so much Mixen.