[Résolu] Problème avec plusieurs ennemis


#1

Voilà, j’ai quasiment fini mon jeu le problème est que je voulait rajouter différents ennemis pour diversiffier alors je leurs donnent les mêmes événements pour qu’il interagissent de la même façon sauf que le nouveau type d’ennemis que j’ai ajouté (Enemy2) N’apparaît jamais, je ne sait pas si je l’explique bien alors je vous des photos du jeu, pour qu vous puissiez voir ce qu’il ne vas pas, demandez moi de l’aide si jamais, j’attends vos réponses Merci!






#2

Salut,
Tu crées tes deux ennemis dans deux blocs distincts, mais tous deux avec le même chrono en condition. Une fois que le premier bloc a remis le chrono à zéro, le deuxième bloc ne peut pas se déclencher.
Tu dois utiliser un autre chrono, ou mettre la ligne de création d’enemy2 dans le même bloc qu’enemy.


#3

Merci de ta réponse je vais tout de suite tester.


#4

J’ai un petit problème, L’applis Gdevelop ne se lance pas même après avoir relancer le PC. J’ai installer la MAJ “beta 94” avant il se fonctionnait bien , maintenant je double clic sur le raccourci il a un mini chargement de a peine 1 seconde a coter de mon curseur puis rien, c’est plutôt embêtant…


#5

La beta 94 est très instable du a un gros changement interne. C’est pour ça qu’il y a marqué pré-version sur Github. Reinstalle la beta 93.


#6

Je l’ai réinstaller et elle fonctionne, par contre j’ai essayer tes deux techniques mais a chaque fois ca causais des bugs au jeux et enemy2 devenait invisible et parfois en tirant je le touchais et ça me mettait 5 points mais il y avait des bugs du style s’il me touche (enemy2) je marque 5 point alors qu’il est invisible, donc ça ne marche pas,


#7

J’ai vu mais j’ai installer la beta 93 il me semble, en faite en au des forum il y avait un message me disant de désinstaller beta 89 puis installer beta 93 et le truc c’est que le fichier qu’il donnait en haut du forum c’était la beta 94 étant donner que lorsque je l’ai lancé il y avais le changelog de la beta 94 donc pas faire grand chose a par attendre la prochaine update…


#8

Problème du forum résolu, je n’avais simplement pas appliquer de force a l’objet enemy! Par contre mon animation d’explosion de s’effectue pas a l’endroit ou est l’énemy.


#9

(je poste trop de message moi même) tou va bien le forum est résolu j’ai juste appliquer a sa position l’explosion merci qand même d’être venu!!


#10

@Starz Concernant les problèmes avec la b94, si tu dispose d’indice pouvant permettre la reproduction de ton bug je suis preneur je remonterais le soucis.


#11

@Bouh He bien j’ai télécherger le fichier via le message en haut de ce forum, j’ai pris la version windows, j’ai désinstaller la b89 en prenant soin de garder de côté mes projets car il allait sinon êtres complètement supprimer, ensuite j’ai fais une mauvaise manip j’ai désinstaller la b89 en même temps que j’ai installer la b94 donc une fois les deux processus terminer la b94 ne s’était pas installer car j’ai supprimer la b89 alors que la b94 allais dans le même répertoire que la b89, j’ai donc encore installer le b94 qui avais donc été supprimer (peut-être pas entièrement car je n’était pas aller voir dans le fichier Roaming de mon pc voir si il n’y avait plus le fichier Gdev.) une fois réinstaller puis l’appli se lance automatiquement, j’ai le changelog de la b94 qui apparait et tout fonctionne très bien. puis bien plus tard je ferme l’applis éteint mon pc, puis le lendemain (aujourd’hui) je double clic sur l’icone de Gdevelop 5 et il n’y a q’un micro chargement de windows a coté de mon curseur et rien même après plusieurs essai même avec les droits administrateurs, donc je garde mes fichiers projets de coté je désinstalle l’appli, puis la réinstalle ensuit je remet mes fichier projest dans le dossier “Gdevelop Projects” puis lance l’appli (qui ne s’est pas lancé automatiquement) et la pas de changelog qui apparait, (peut être a-t-il reconnu mon système et donc ne me la pas afficher) et là l’appli est en englais alors que la première fois elle était en français, et c’est tout là je ne l’ai pas encore fermée car je travail dessus. En prenant compte que mon PC date de 2016. Bonne chance a vous!