[Résolu] Je n'arrive pas à mettre du son ><''


#1

salut!!

J’ai commencé à utiliser gdevelop il y a qqs jours.
Je créé un petit je de plate forme, et tt à l’heure j’ai essayé d’ajouter de la musique et du son, mais en vain. J’ai essayer pleins d’évenements pour mettre du son, mais à chaque fois, quand je lance l’apperçu ou le jeu compilé, c’est le silence total: pas de musiques, pas de sons, rien…
J’ai essayé de regarder sur internet, mais j’ai rien trouvé
Qqn peut m’aider? =)


#2

Alors les actions pour la musique sont déconseillées et il faut avoir interragit avec la page avant de pouvoir mettre du son.


#3

Interagir? C’est-à dire?


#4

Les ressources peuvent être encore en chargement au début du jeu.
Donc elle ne sont pas lu et les gens disent que ça marche pas.
Mais les ressources sont prêtes pour la scène suivante en général !

Je recommande à tous les utilisateurs de créer une scène vide avec seulement du texte de base et d’afficher “Appuyez sur une touche”.
Et charge la scène suivante ensuite où tu utilisera tes ressources.
Pendant ce court laps de temps ou tu attend une touche, la ressource à le temps de se charger un minimum et sera prête à être utilisée dans la scène suivante.

Par ressource j’entend :

  • Les font/police d’écriture
  • La vidéo
  • Le son
  • La musique
  • Les fichiers utilisé par les événement aussi surement.

Je sépare son et musique car le moteur de jeu fait la différence, un son est court, une musique est plus longue.
Plus d’infos

Pour la vidéo (Info sur la vidéo), le son et la musique :
Et c’est absolument nécessaire avant de les lire parce que le moteur est limité par le Chromium fourni dans Electron.
Et votre jeu est lancé avec Chromium ou un navigateur (navigateur qui on en grande partie une base de Chromium haha).
Donc le moteur a toujours cette limite des navigateurs qui nous est pas vraiment possible de contourné pour l’instant.

Donc l’utilisateur doit interagir avec le jeu avant.

(Il y a un patch sur le son pour la prochaine mise à jour mais j’ai survolé l’info donc je sais pas trop de quoi il s’agit B83+)

Hésitez pas a link cette réponse si vous voyez d’autres questions de ce style :wink:


#5

Alors, j’ai essayé, ça marche vraiment pas, même à la 4e scène en attendant 10 minutes, toujours aucun son =(
J’ai même essayé de créér une scène qui fait juste du son quand je clique gauche, mais toujours aucun bruit…


#6

quel est ton fichier audio ?


#7

Putain chuis con mes fichiers étaient corrompus!
je suis désolé de vous avoir dérangés pour rien,
merci quand même ^^