Jump only once even when holding the jump key


#1

HI everyone first time here, my character continuously jumps like a grasshopper when i hold the jump key
how can we do to make the character only jump once when pressing the jump key


#2

maybe try trigger once?


#3


set the command you see on the right. It only needs to be set at the beginning of the scene, so use the command you see on the left


#4

Try adding a Trigger once, or changing “key pressed” to “key released”.


#5

use the alternative key (not space key, because it is default key for jumping) for example UP key. this my suggestion:

in the condition editor:
UP Key is pressed
Trigger once

in the action editor:
Simulate pressing Jump for Player (or your object name that you wanna jump)

thas it. I Have try, and it works. the Player, jumping only once when the Up key pressed although for long time.


#6

OoO thanks you’re right just tried


#7

There’s alternative way: just select a player -> there’s should be Platformer behaviour. If yes, you need to uncheck “Default controls”.

Note: if you do this, then you need use “Key name pressed” -> “Simulate key name for player”