Glitch encountered with Piskel

I was working on my game that I am making sprites for using Piskel, and all of my sprites so far have been made using it. All of a sudden when I tried to make a new sprite, the Piskel editor doesn’t give me anything to draw on, and anything I press doesn’t do anything. Here is a picture:

Does anyone know what is going on? I don’t want to have to resort to finding another editor so I can make my sprites. Please, if anyone knows, give me some help. Thanks!

Have you tried turning it off and on again? :nerd_face:

Yea, I closed the project and exited gdevelop, and it was the same when I opened it again.

1 Like

Just a little advice for the future: use Print screen keys (“prt sc” and Windows icon) to do a screenshot

Thanks, I tried doing ctrl+prt sc for like 5 minutes and it didn’t work so I gave up.

No, it’s not ctrl, because it’s different key. You need use a key with Windows logo

Try to uninstall and reinstall Gdevelop then.

Am I able to take my game out of the gdevelop directory and put it back in when I reinstall? If not, I guess I’ll just find another drawing editor and upload those to gdevelop.

The install folder should not be your game folder, but if it is, inside Gdevelop, open your project and pick File/Save as… to save your project to a new folder.

Ok, I’ll try that. Thanks

I removed all of my sprites and the game file from the gdevelop directory and kept them while I uninstalled Gdevelop. When I reinstalled it and put everything back in, everything was there, but I was still having that same glitch.

Did you installed a new version of program?

Yea, I went to the website and installed the windows version.

Is this problem in all projects or only the one you are working on?

I’ll have to try. I might have tried and it didn’t work already, but I’ll test it again. If that doesn’t work, I’ll just find another pixel editor and upload the sprites.

I tried it, and still got the same problem. I’ll probably just install it separately or get a different editor.

I experienced the same when I try to edit “Tiled Sprite” with piskel. For “Sprite” it works fine.

Thanks for the info. Anyways, I’m using a separate version of Piskel where I save the sprites as a .png file and I can put it into gdevelop, so this thread is kinda dead now. Thanks for the help though!

Guy’s can you write here the full path of your files for the tiled sprite and for the classic sprite please ?

I lost that project. As far as I can remember, classic sprite file was in game folder C:\Users\saini\Documents\GDevelop projects\My project and tiled sprite(file with .piskel extension) was imported from downloads folder directly into piskel.