Game with Black Bars


#1

The preview of the game, and also the game itself, has blackbars when in windowed. In fullscreen the blackbars are smaller but still present.
The thing is that the background and everything is the according size, so how can I get rid of them?
Btw, the res is 1920x1080 .
The black bars are at the sides of the game.


#2

Keep in mind that preview has the title bar, and it cannot be hidden. This means in full screen you’ll have black bars.

Try compiling your game or exporting it to HTML5 then throwing it on Itch and you shouldn’t have that issue unless your screen resolution settings (Game Settings > Properties > “Game Resolution Resize”) mode is set strange.


#3

My game has black bars even in windowed.
If it was only for the full screen, it wouldn’t be a problem.


#4

Hmm…looks like it’s just the preview. I set my game demo to 1920x1080 and got the black bars in preview ,but upon compiling they’re not there.


#5

I exported the game and the black bars are still present.


#6

Sadly, I can’t reproduce the issue and I’ve tried a few different demos. If you feel comfortable doing so, upload a zip of your project files and I can take a look sometime tonight.